Support Center

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Mountain Lion Firewall Blocks Actions

Leon Feb 14, 2013 08:10PM UTC

I cannot get Actions on my iPad to connect to my MacBook Pro running 10.8.2 unless I turn the firewall off. I have confirmed that when the firewall is on, Actions Server is set to allow incoming connections. I have no problem connecting to my Mac Pro running 10.7.5 or with Windows 7 VM running on the Mac Pro.

Up 6 rated Down
Cristiano Feb 16, 2013 03:00PM UTC Actions S.r.l. Team

Hi Lion

i think that Actions server is indeed not authorized by your firewall, as it works when the firewall is off. Can you please check its status in your firewall options? Go to System Preferences > Security & Settings > Firewall and click Firewall Options… (you should eventually first unlock the settings in the lower left area of the panel)

I attach an image of the panel.

firewall options Os X

Let us know if this solves your issue.

regards

Marco

Up 9 rated Down
Leon Mar 01, 2013 02:17PM UTC
As I mentioned in my original post, I have already verified that Actions Server.app was showing up in the firewall as Allow incoming connections. Despite this proper configuration, I still can't connect.
Up 9 rated Down
Cristiano Mar 04, 2013 11:00AM UTC Actions S.r.l. Team

Thank you Leon,

i bet there was indeed an issue in the Mac firewall, even if you were sure ActionsServer was authorized, as you say that turning the firewall off you can connect. We don’t have any report about this kind of issue under mac 10.8. Do you have any third-party additional protection modules linked to the OS firewall?

What connection mode are you using for Actions? Automatic detection or Custom IP address?

Let me know

Regards

Marco

Post Your Public Answer

Your name (required)
Your email address (required)
Answer (required)
support@getactionsapp.com
http://assets0.desk.com/
false
usefoolapps
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete